Unable to ssh into beaglebone board v2.8

So I’m currently trying to ssh into the beaglebone board used for the ROV, with v2.8 flashed onto it. I’m using a mac, and currently I’m powering it using the mini-usb cable and I’ve run an ethernet cable from the board directly into my laptop (so it’s not set up using the Tenda homeplug at the moment).

Whenever I power the board on, in the network it’ll start out saying it’s connected while the board is initializing (the circle will be green), but once it’s finished initializing it kills the connection and say the board is unplugged (circle turns to red). I’m unable to ping the board at 192.168.254.1 both while it’s initializing or after, and running nmap -sn 168.198.254.0/24 doesn’t show there are any devices connected over that IP range.

Block Image

Block Image

I’ve additionally heard that the IP address for the usb port is 192.168.7.2 so I’ve tried that address to see if the mini usb is causing issues but I’ve had no success.

What’s odd to me is that it’s recognizing there’s a device attached at first, so it’s trying to connect, but then it gets denied access and says cable is unplugged. Additionally for what it’s worth all four LED’s are on and I was using the SD card purchased from the site however I’ve also flashed my own SD to see if the image was the problem and I’ve had the same issues (I’ve also tried a separate ethernet cable with no luck). Lastly I turned on network sharing, and I’m able to connect to my raspberry pi using a similar method (which makes me suspect either there’s a firewall on the board keeping me out or something’s disabled on the board).

Thanks for your help!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment